Friday, July 22, 2011

Visual Studio Crashes on Open

After installing Internet Explorer my Windows Search stopped working and Visual Studio 2010 started crashing, reporting an exception in .Net 20r3 or something like that. The app would crash after opening a solution, right after the window "configuring solution" would close.

Fortunately, the fix was easy - deleting the .suo files made it go away the first time.

Problem details:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: devenv.exe
Problem Signature 02: 10.0.40219.1
Problem Signature 03: 4d5f2a73
Problem Signature 04: mscorlib
Problem Signature 05:
Problem Signature 06: 4d53693b
Problem Signature 07: 2c26
Problem Signature 08: 45
Problem Signature 09: KUTS43RW3WMPE3EWT1R1Z5M5MTM1NR04
OS Version: 6.1.7600.
Locale ID: 3081

Additional information about the problem:
LCID: 1033

However, now I could only open the project/solution but opening a file in the project or trying to recompile would crash the Visual Studio again. Running "devenv.exe /log" creates an xml log file:


One of the last entries contained the error message. According to forums, this could be related to Silverlight. So I removed all the installed components related to Silverlight. The problem is that Silverlight 4 Tools cannot be installed after the Visual Studio SP1. So I removed the Service Pack. Uninstallation requires reboot.

After that I installed the Silverlight Tools and reapplied the Visual Studio SP1. Since that bore no results, I reapplied Windows 7 Service Pack 1 and all the software above in various order.

However, it turned out that unplugging the (new) RAM sticks out and plugging them back in again fixed the problem!

No comments: