Pages

Thursday, December 20, 2012

Issue with Maps API on Cyanogenmod 10.1


Cyanogenmod 10.1 is out for Samsung Galaxy S2 (i9100), with Android 4.2.1. There is also new gapps package with Google libraries.
However, after installing these, all the apps depending on Google Maps API are failing to start or install.

The message that pops up during installation is "Error: Missing shared library."
Looking at logcat, this is the full error message: "E/PackageManager( 2208): Package com.google.android.apps.unveil requires unavailable shared library com.google.android.maps; failing!"

I fixed permissions on the files below:
/system/etc/permissions/com.google.android.maps.xml
/system/framework/com.google.android.maps.jar

The missing permissions were "read" for everyone. After changing these, the apps that use Maps API worked again!

3 comments:

James Yale said...

I've been trying to fix this issue for ages now, thanks!

Corrected the permissions, rebooted and now Google+ and all the other applications which were reported as incompatible are working.

Matt Hirsch said...

Thanks! This was really helpful.

Matt Hirsch said...

Thanks, this was really helpful!