Saturday, May 09, 2015

Lock down dependencies in npm package versions

Shrinkwrap command allows specifying which package versions to use. Often there is a mess when upgrading one package in a chain, or (trying) migrating from Node to io.js, when one package doesn't work and brings down all the others that depend on it.

shrinkwrap | npm Documentation

No comments: